summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDan Beste2017-11-07 20:40:55 -0600
committerDan Beste2017-11-07 20:40:55 -0600
commit2e75c13759eaff478e80d2063f60ecec5f97d055 (patch)
tree82ab9fd8d158db98e9c99f17814206446811b3da /PKGBUILD
downloadaur-python-justbases.tar.gz
v0.12
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e942f5cfafb1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Dan Beste <Dan.Ray.Beste@gmail.com>
+
+pkgname='python-justbases'
+pkgver=0.12
+pkgrel=1
+pkgdesc='Conversion of a rational number to a representation in any base.'
+arch=('any')
+license=('GPLv2')
+url='https://github.com/mulkieran/justbases'
+depends=('python-six')
+makedepends=('python-tox')
+source=(
+ "${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
+)
+sha256sums=(
+ '22273facc37cc54bdcd15bc6632306539783520922c7bbdef6b4c1bc50d9b15b'
+)
+
+check() {
+ cd "${pkgname/python-}-${pkgver}"
+
+ msg2 "Skipping: coverage"
+ msg2 "Skipping: lint"
+ tox -e test
+}
+
+package() {
+ cd "${pkgname/python-}-${pkgver}"
+
+ python setup.py install --root="${pkgdir}"
+}
+
+# vim: ts=2 sw=2 et: