summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLiam Timms2021-04-27 15:24:21 -0400
committerLiam Timms2021-04-27 15:24:21 -0400
commita78301b9cd459ed0bb3d29ca1e33c12ab1caa611 (patch)
tree0e5f7ea157b6100c7d5662af0dcbf9d1bff2fb44 /PKGBUILD
downloadaur-python-kmeans1d.tar.gz
initialization
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..21c2083449a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Liam Timms <timms5000@gmail.com>
+
+pkgname=python-kmeans1d
+_pkgname=kmeans1d
+pkgver=0.3.1
+pkgrel=1
+pkgdesc='convenient access to the OpenAI API from applications written in the Python language.'
+arch=('any')
+url='https://openai.com/'
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools')
+optdepends=()
+source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/dstein64/${_pkgname}/archive/v${pkgver}.tar.gz")
+sha512sums=('ab2999e839fc584ecd05251374eef0122b8b44d512d7d441db783d5a3e2a1f5342b3f2d65f85f6f27969bdee179f02b881cdfda104f5da9bed0caa6d60c6b9a9')
+
+build()
+{
+ cd "$srcdir/${_pkgname}-$pkgver"
+ python setup.py build
+}
+
+
+package()
+{
+ cd "$srcdir/${_pkgname}-$pkgver"
+ python setup.py install --skip-build --root="$pkgdir" --optimize=1
+ # install -Dm644 COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+