summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStefan Gehr2024-04-23 14:55:37 +0200
committerStefan Gehr2024-04-23 14:55:37 +0200
commitef5a857ab666f0aed865c9a858674d98567c023d (patch)
treeef6697d9cc0fceff24a406291c8dcb54f799486a /PKGBUILD
parent92f19813aeb790218491c38e6d22b6fd7fab7ef2 (diff)
downloadaur-python-krpc.tar.gz
Use the recommended install method from the ArchWiki
https://wiki.archlinux.org/title/Python_package_guidelines#Standards_based_(PEP_517)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b594311fcf12..e9ffab88d83b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,17 +9,17 @@ pkgdesc="Client library for kRPC, a Remote Procedure Call server for Kerbal Spac
url="https://github.com/krpc/krpc"
license=("LGPL3")
arch=('any')
-makedepends=('python' 'python-setuptools')
+makedepends=(python-build python-installer python-wheel python-setuptools)
source=("https://github.com/krpc/krpc/releases/download/v$pkgver/krpc-python-$pkgver.zip")
b2sums=("467d328729e9978d0aa4b1d42ac2a2c68c584dd55e38f94d7151037fe06fb865e2dfdec5c90c287da06ecbcc546c017b5cd8c1a769c23b5f71c059ff3165b460")
build() {
cd $_pyname-$pkgver
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd $_pyname-$pkgver
- python setup.py install --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}