summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkyope2024-02-17 18:48:09 +0800
committerkyope2024-02-17 18:48:09 +0800
commit4251ce363a96f280efe1a96d23cb171e408f54e7 (patch)
tree1fc52e792b8949dfbe75d47c3e0202c72d98808b /PKGBUILD
downloadaur-python-latex-ocr-server.tar.gz
v0.1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..13cb91c5120a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: vvxxp8 <concatenate[g] the characters[x] in square[b] brackets[1] in[5] order[3] at gmail dot com>
+
+pkgname=python-latex-ocr-server
+pkgver=0.1.0
+_archive=latex_ocr_server-${pkgver}
+pkgrel=1
+pkgdesc="A protobuf-based service to generate latex equations from image files"
+arch=(x86_64)
+url="https://github.com/lucasvanmol/latex-ocr-server"
+depends=(python-huggingface-hub)
+makedepends=(
+ python-build
+ python-installer
+ python-setuptools
+ python-wheel
+ python-hatchling
+)
+source=("${_archive}.tar.gz::https://github.com/lucasvanmol/latex-ocr-server/releases/download/${pkgver}/${_archive}.tar.gz")
+sha512sums=('44a40bc4cc175233da9fdb23cbd4e7f4ac7eae15f94a39a4cd93e66a034c1a58122db23b953af28cad83df4f38eb6c4ad35c5a0d5a3a296f7a925c9cbd11d2f8')
+
+build() {
+ cd "$_archive"
+
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$_archive"
+
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}