summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoraiyion.prime2019-05-07 10:46:42 +0200
committeraiyion.prime2019-05-07 10:46:42 +0200
commitd9bf006bc43445b2b42edcdca460f1f25b0a3403 (patch)
treedab28be44a30d509cb79cd9651d80d3390d723f3 /PKGBUILD
parent5b0bf00b46f3f7b5281674351bee2eb7a295c7fe (diff)
downloadaur-python-libcharon.tar.gz
removed python-typings dependency as it was added to the standard library in python 3.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a7ad64070ffe..5de36aceb375 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,16 @@
# Maintainer: Aiyion <aur@aiyionpri.me>
pkgname=python-libcharon
pkgver=4.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="File metadata and streaming library"
arch=('any')
url="https://github.com/Ultimaker/libCharon"
license=('LGPL3')
-depends=('python' 'python-typing')
+depends=('python')
+
+# the python typing extensions are not necessary anymore, unless you are using an ancient version of python and can not move away from that
+optdepends=('python-typing-extensions')
+
makedepends=('python-setuptools' 'cmake')
checkdepends=('python-pytest' 'python-coverage')
source=("$pkgname-$pkgver.tar.gz::https://github.com/Ultimaker/libCharon/archive/${pkgver}.tar.gz")