summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXeonacid2021-03-11 17:41:37 +0800
committerXeonacid2021-03-11 17:41:37 +0800
commit31b8f728cbbe2e6878149615b6f200557def23d7 (patch)
treeb261b8cdbd9b13a208d662a7dbf9140584958ab6 /PKGBUILD
downloadaur-python-libcsearcher.tar.gz
bump 1.1.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3f7a9b3ddd64
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Xeonacid <h.dwwwwww at gmail dot com>
+
+pkgname=python-libcsearcher
+_pkgname="LibcSearcher"
+pkgver=1.1.5
+pkgrel=1
+pkgdesc="Python wrapper for libc-database."
+arch=('any')
+url="https://github.com/IZAY01/LibcSearcher"
+license=('BSD')
+depends=('python-requests')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('302246d0e5bcb0aa1c464f65ef349c85f82520120d45ca5a58d3445d45833f76')
+
+build() {
+ cd "$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}