summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVictor Roest2021-02-08 10:31:40 +0100
committerVictor Roest2021-02-08 10:32:59 +0100
commit55a144549635b3c4d609790c312fd76a09d04192 (patch)
treed7423183fdb9f4a802e334d5e86d479bd9ba7aaf /PKGBUILD
downloadaur-python-matrx-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1893d2cd1ecf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Victor Roest <victor@xirion.net>
+_name=matrx
+pkgname=python-matrx-git
+pkgver=v2.0.5.r0.g957ca9e
+pkgrel=1
+pkgdesc='A Python package for the rapid development and evaluation of human-agent teaming concepts.'
+arch=('x86_64')
+url='https://www.matrx-software.com/'
+license=('MIT')
+depends=('python-flask' 'python-jsonpickle' 'python-flask-socketio' 'python-numpy' 'python-requests' 'python-colour' 'python-gevent' 'python-flask-cors' 'python-docutils' 'python-pygments')
+source=("git+https://github.com/matrx-software/${_name}.git")
+sha512sums=('SKIP')
+
+build() {
+ cd "$_name"
+ python setup.py build
+}
+
+package() {
+ cd "$_name"
+ export PYTHONHASHSEED=0
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}
+
+pkgver() {
+ cd "$_name"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}