summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlilac2024-12-23 17:08:07 +0800
committerlilac2024-12-23 17:08:07 +0800
commite0c98c9d3b8cf7a9d1e85a70cd8276d81ef61e82 (patch)
tree6814eb3f3f3311373d88403fe3dd09286663cb2b /PKGBUILD
parent01c63537621cfea6beec6e07e3a2bc0c17d93537 (diff)
downloadaur-python-mmaction2.tar.gz
[lilac] updated to 1.2.0-5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bd2a8d7a0b7d..89529ac2b9e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=mmaction2
pkgname=python-mmaction2
pkgver=1.2.0
-pkgrel=4
+pkgrel=5
pkgdesc="OpenMMLab's Next Generation Action Understanding Toolbox and Benchmark"
arch=('any')
url='https://github.com/open-mmlab/mmaction2'
@@ -36,6 +36,10 @@ optdepends=(
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/open-mmlab/mmaction2/archive/v${pkgver}.tar.gz")
sha512sums=('ccedf843db145971a61ecaea23d6334d4d27896b9506200734b29f331efbb52cd551a23b8c9d68398f4c1930a62cdd8b370200c7934fe9acb38de6069965811e')
+prepare() {
+ sed -i "s/version=get_version()/version='$pkgver'/" "${srcdir}/${_pkgname}-${pkgver}/setup.py"
+}
+
build() {
cd "${_pkgname}-${pkgver}"
python -m build --wheel --no-isolation