summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChih-Hsuan Yen2018-11-09 06:47:15 +0800
committerChih-Hsuan Yen2018-11-09 06:47:15 +0800
commit8491e084f6df2d29d6c07bc523456fb31ac208ae (patch)
tree0d2c542455049ebcb2ccd5d3a26c5f06d2fa08d7 /PKGBUILD
parentaa11e5b962d31670c2aba298852d02391f65178d (diff)
downloadaur-python-moto.tar.gz
Bump to 1.3.7
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 12 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 50b80ee09e0d..29add6053273 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,46 +3,48 @@
pkgname=python-moto
_pkgname=moto
-# Wrong tag? https://github.com/spulec/moto/pull/1733#issuecomment-423787842
-_commit=57f9691a52245ffd9d7c0317e90953d054070c65
-pkgver=1.3.6
+pkgver=1.3.7
pkgrel=1
pkgdesc="Moto is a library to mock out the boto library."
arch=('any')
url="https://github.com/spulec/moto"
license=('Apache')
-depends=('python-aws-xray-sdk' 'python-boto' 'python-boto3-legacy'
+depends=('python-aws-xray-sdk' 'python-boto' 'python-boto3'
'python-cryptography' 'python-dateutil' 'python-docker' 'python-jinja'
'python-jsondiff' 'python-jose' 'python-mock' 'python-pyaml'
'python-pytz' 'python-requests' 'python-responses' 'python-xmltodict'
'python-werkzeug')
checkdepends=('python-flask' 'python-freezegun' 'python-nose' 'python-sure' 'tk')
makedepends=('python-setuptools')
-source=("$pkgname-$pkgver.tar.gz"::"https://github.com/spulec/moto/archive/$_commit.tar.gz"
+source=("$pkgname-$pkgver.tar.gz"::"https://github.com/spulec/moto/archive/$pkgver.tar.gz"
remove-dep-upper-bounds.patch)
-sha256sums=('d8fc2c169faf9cea3973a00b51e87a512e81002e2c12d06cef9f02db33c12471'
+sha256sums=('5431738fef3bc3b589e37123df496b63d3c1348a49f3632d1c05da566b839cbe'
'f7c965571483b5b77419b0448ec98675bf4ec2b657c95dc7320d1eb1f2b81fb9')
prepare() {
- cd $_pkgname-$_commit
+ cd $_pkgname-$pkgver
patch -Np1 -i ../remove-dep-upper-bounds.patch
}
build() {
- cd $_pkgname-$_commit
+ cd $_pkgname-$pkgver
python setup.py build
}
check(){
- cd $_pkgname-$_commit
+ cd $_pkgname-$pkgver
+
+ # https://github.com/spulec/moto/issues/1924
+ export AWS_SECRET_ACCESS_KEY=foobar_secret
+ export AWS_ACCESS_KEY_ID=foobar_key
TZ=UTC nosetests -sv ./tests/ --exclude='test_iot.*' --exclude='test_lambda.*'
}
package(){
- cd $_pkgname-$_commit
+ cd $_pkgname-$pkgver
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}