summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLucas Heitzmann Gabrielli2018-02-15 10:49:42 -0200
committerLucas Heitzmann Gabrielli2018-02-15 10:49:42 -0200
commit75f6230112d77bd4965265324d515c73baec4336 (patch)
treeafd10ffa4727416b0fdfd9733078e19204786335 /PKGBUILD
parent7872cfdaa8edfc31d227db8f2ee9662bcb45a28f (diff)
downloadaur-python-mshr-git.tar.gz
Split python interface
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 7 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b82532c71bb6..34081aa521d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
_base=mshr
_fragment="#branch=master"
pkgname=python-${_base}-git
-pkgdesc="Mesh generation component of FEniCS"
-pkgver=20170224
+pkgdesc="Mesh generation component of FEniCS (python interafce)"
+pkgver=20180104
pkgrel=1
arch=('i686' 'x86_64')
url="https://bitbucket.org/fenics-project/${_base}"
license=('GPL3')
groups=('fenics-git')
-depends=('python-dolfin-git' 'mpfr')
+depends=('mshr-git')
makedepends=('git')
options=(!emptydirs)
source=("${_base}::git+https://bitbucket.org/fenics-project/${_base}.git${_fragment}")
@@ -22,26 +22,13 @@ pkgver() {
}
build() {
- cd ${_base}
- [ -d build ] && rm -rf build
- mkdir build
- cd build
-
- local py_interp=`python -c "import os,sys; print(os.path.realpath(sys.executable))"`
-
- cmake .. \
- -DCMAKE_INSTALL_PREFIX="${pkg}"/usr \
- -DPYTHON_EXECUTABLE="${py_interp}" \
- -DCMAKE_SKIP_BUILD_RPATH=TRUE \
- -DCMAKE_SKIP_RPATH=TRUE \
- -DCMAKE_BUILD_TYPE="Release"
-
- make
+ cd ${_base}/python
+ python setup.py build
}
package() {
- cd ${_base}/build
- make install DESTDIR="${pkgdir}"
+ cd ${_base}/python
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
}
# vim: shiftwidth=2 softtabstop=2 tabstop=2 noexpandtab