summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWill Handley2020-05-23 20:52:40 +0100
committerWill Handley2020-05-23 20:52:40 +0100
commit4c90a09337ee63b379882411146e48b7767c5158 (patch)
treec59c4f320486ebf62401cc0803c919ff30e8d0b3 /PKGBUILD
downloadaur-python-multinest.tar.gz
put pymultinest into a separate package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..73e543e5ba87
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
+pkgname=python-multinest
+pkgver='3.12'
+pkgrel=1
+pkgdesc="MultiNest is a Bayesian inference tool which calculates the evidence and explores the parameter space which may contain multiple posterior modes and pronounced (curving) degeneracies in moderately high dimensions."
+arch=(any)
+url="https://github.com/JohannesBuchner/PyMultiNest"
+groups=()
+depends=('multinest')
+license=('custom')
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=(
+ "${url}/archive/b147515e950cf225befef3f0e26408c672f01979.tar.gz"
+)
+sha256sums=(
+ 'cebd358d24044863560d80e43436414a9341c25a25d572db1851a507ecf59bfc'
+)
+package() {
+ cd "${srcdir}/PyMultiNest-b147515e950cf225befef3f0e26408c672f01979/"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+