summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLukasz Michalski2020-11-05 16:46:44 +0100
committerLukasz Michalski2020-11-05 16:46:44 +0100
commit19471e2c572414e1a7ff1fc8dbc46e7ab0fbd069 (patch)
tree7c0fbbe17d4848c6190155e45fe0357aba664bb8 /PKGBUILD
downloadaur-python-nagiosplugin.tar.gz
first version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..542f59eca7c5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Lukasz Michalski <lm@zork.pl>
+
+pkgname=python-nagiosplugin
+pkgver=1.3.2
+pkgrel=1
+pkgdesc="a Python class library which helps writing Nagios (or Icinga) compatible plugins easily in Python"
+arch=('any')
+url="https://github.com/mpounsett/nagiosplugin"
+license=('ZPL2.1')
+depends=('python')
+makedepends=('git' 'python-setuptools')
+source=("git+https://github.com/mpounsett/nagiosplugin.git#tag=$pkgver")
+sha256sums=('SKIP')
+
+build() {
+ cd "$srcdir/nagiosplugin"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/nagiosplugin"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}