summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authora8212023-05-04 11:17:13 +0200
committera8212023-05-04 11:17:13 +0200
commit0fe86b20aa39c31238b2449da2f8246db581310c (patch)
tree671d23186bc9942b5330b9cdc5595db68d521910 /PKGBUILD
parentc85ae1bd78bff8fffc8c955d012906fe270fc1a2 (diff)
downloadaur-python-name-that-hash.tar.gz
Adopt and bump for python 3.11 rebuild
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 16 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e88f007b676f..4e9f241bc36a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,30 @@
-# Maintainer: amadejpapez <amadej.papez@gmail.com>
+# Contributor: amadejpapez <amadej.papez@gmail.com>
pkgname=python-name-that-hash
_pkgname=Name-That-Hash
pkgver=1.11.0
-pkgrel=6
+pkgrel=7
pkgdesc="The Modern Hash Identification System."
arch=("any")
url="https://github.com/HashPals/Name-That-Hash"
license=("GPL3")
depends=("python" "python-click" "python-rich")
-makedepends=("python-installer" "python-poetry-core" "python-wheel")
-source=("https://files.pythonhosted.org/packages/19/7a/731c96302f39610f1ce6742a4e5b997d621b06f5608dc939f5cd48a639a0/name_that_hash-1.11.0-py3-none-any.whl")
-sha256sums=("59682a35714235d958e723d658c0874abb81edf77ceb9d81d7e6416bc2af3b84")
+makedepends=("python-build" "python-installer" "python-poetry-core" "python-wheel")
+checkdepends=("python-pytest")
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('2f8dd4beaf7326d2f664f18205c024848dcb627ff29ceffb22ab410fbef2d761')
+check() {
+ cd $_pkgname-$pkgver
+ pytest
+}
-# NOTE: for now install directly via wheel as I was getting the
-# ModuleNotFoundError: No module named 'name_that_hash'
-# error after installation and cannot look into it right now
-
-# build() {
-# cd $_pkgname-$pkgver
-# python -m build --wheel --skip-dependency-check --no-isolation
-# }
+build() {
+ cd $_pkgname-$pkgver
+ python -m build --wheel --skip-dependency-check --no-isolation
+}
package() {
- python -m installer --destdir="$pkgdir" *.whl
- # install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd $_pkgname-$pkgver
+ python -m installer --destdir="$pkgdir" dist/*.whl
}