summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-05-27 19:41:06 -0500
committerCarlos Aznarán Laos2023-05-27 19:41:06 -0500
commit50561a0108cc315945234e4f927596f99de492fc (patch)
tree550072e7f70b75a213f84a8175a3885fa0dafde8 /PKGBUILD
parentd0f294497d87fd2ffed797f8c51dbeac14749801 (diff)
downloadaur-python-ngmix.tar.gz
Bump version to 2.3.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD59
1 files changed, 30 insertions, 29 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dac645ffa95d..a573c0310fc1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,45 @@
-# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: Andres Alejandro Navarro Alsina <aanavarroa@unal.edu.co>
# Contributor: Erin Sheldon
-
-pkgname=python-ngmix
-_pkg="${pkgname#python-}"
-pkgver=2.2.0
+_base=ngmix
+pkgname=python-${_base}
+pkgver=2.3.0
pkgrel=1
-pkgdesc='Gaussian mixtures and image processing'
-arch=('any')
-url="https://github.com/esheldon/ngmix"
-license=('GPL')
-depends=('python-numpy' 'python-numba')
-optdepends=(
- 'python-galsim: for metacalibration operations'
- 'python-scikit-learn: for sampling multivariate PDFs'
- 'python-scipy: for image fitting using Levenberg-Marquardt fitter')
-makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
-# checkdepends=('python-pytest' 'python-galsim' 'python-scikit-learn' 'python-scipy')
-changelog=CHANGES.md
-source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
- 'setup.py.patch')
-sha256sums=('a499f5b0ae5888f50fb97e8b59107d529f296b7a0047129f629aa4e99ef7df06'
- '85057d5ec4f082a3599084dbe0e874be2af2a0f91786a10933b3368e6e025898')
+pkgdesc="Gaussian mixtures and image processing"
+arch=(any)
+url="https://github.com/esheldon/${_base}"
+license=(GPL)
+depends=(python-numba)
+optdepends=('python-galsim: for metacalibration operations'
+ 'python-scipy: for image fitting using Levenberg-Marquardt fitter'
+ 'python-scikit-learn: for sampling multivariate PDFs')
+makedepends=(python-build python-installer python-setuptools python-wheel)
+# checkdepends=(python-pytest python-galsim python-scipy python-fitsio python-flaky python-metadetect) # python-scikit-learn
+source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz
+ setup.py.patch)
+sha512sums=('176a80955f72b5018bbccfee1ec6dc6857975ecb81cb4092f45bff0a50c644f563317a3e74a27346a91974f900ba51f4fe046eab01d9cfa649a404c148bd39c6'
+ 'a0464809ec508f67ffb79dec29088ce2b9d7269c739d66d9a47f7251ae31657d33a2fa5ffa80c37bd50b1c04b72418ef16e104b2dd4e165448f357a193b876a0')
prepare() {
- patch -p1 -d "$_pkg-$pkgver" < setup.py.patch
- sed -i "s/__version__/$pkgver/" "$_pkg-$pkgver/setup.py"
+ patch -p1 -d ${_base}-${pkgver} <setup.py.patch
+ sed -i "s/__version__/$pkgver/" ${_base}-${pkgver}/setup.py
}
build() {
- cd "$_pkg-$pkgver"
- python -m build --wheel --no-isolation
+ cd ${_base}-${pkgver}
+ python -m build --wheel --skip-dependency-check --no-isolation
}
# check() {
-# cd "$_pkg-$pkgver"
-# pytest -x
+# cd ${_base}-${pkgver}
+# python -m venv --system-site-packages test-env
+# test-env/bin/python -m installer dist/*.whl
+# test-env/bin/python -m pytest
# }
package_python-ngmix() {
- cd "$_pkg-$pkgver"
- PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir" dist/*.whl
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}