summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexandrParkhomenko2021-02-04 16:08:59 +0300
committerAlexandrParkhomenko2021-02-04 16:08:59 +0300
commit76c100426cc17be697b1a95db9bb23b7fe095ec8 (patch)
tree7d299af8c0c5b55e27fab597d8f352f45662a599 /PKGBUILD
downloadaur-python-numpy-financial-git.tar.gz
welcome
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b5ad401bed64
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Alexandr Parkhomenko <it@52tour.ru>
+
+_author=numpy
+_pkgname=numpy-financial
+pkgname=python-$_pkgname-git
+pkgver=1.0.0.r20.ge3c2a4e
+pkgrel=1
+pkgdesc='Collection of elementary financial functions'
+arch=(
+ 'any'
+)
+
+url='https://github.com/'
+license=('BSD 3-Clause')
+depends=('python-numpy>=1.15')
+makedepends=('git')
+provide=('numpy-financial')
+source=("git://github.com/$_author/$_pkgname")
+sha256sums=('SKIP')
+
+pkgver () {
+ cd "$srcdir/$_pkgname"
+ git describe --tags --long | sed -r 's/^v//;s/-RC/RC/;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ python setup.py build
+}
+
+check() {
+ cd "$srcdir/$_pkgname"
+ python setup.py test
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ python setup.py install --root="$pkgdir/" --skip-build --optimize=1
+ install -Dm644 "LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}