summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarco Rubin2023-10-28 13:18:32 +0200
committerMarco Rubin2023-10-28 13:18:32 +0200
commitfd35e2b2a38de9a7cac0cfa015e7b3bccd0b0833 (patch)
treed094a8352113650bdbf4a156a2856fe67248b26c /PKGBUILD
parent5327d8545943683f06a4f43860d4efd384280c43 (diff)
downloadaur-python-nxviz.tar.gz
added python-setuptools, removed useless quotes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4d44861fd487..4ee07742029e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_name=nxviz
pkgname=python-$_name
pkgver=0.7.4
-pkgrel=1
+pkgrel=2
pkgdesc='Visualization Package for NetworkX'
arch=('any')
url='https://github.com/ericmjl/nxviz'
@@ -18,17 +18,17 @@ depends=(
'python-pandas>=1.2.0'
'python-seaborn>=0.11.1'
)
-makedepends=(python-build python-installer python-wheel)
+makedepends=(python-build python-installer python-setuptools python-wheel)
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
sha256sums=('9499b8feadffe257fef580c8300c74e5dd902924901e8050f96b0ad15f18eb22')
build() {
- cd "$_name-$pkgver"
+ cd $_name-$pkgver
python -m build --wheel --no-isolation
}
package() {
- cd "$_name-$pkgver"
+ cd $_name-$pkgver
python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}