summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicholas Yim2018-07-26 18:24:55 +0800
committerNicholas Yim2018-07-26 18:24:55 +0800
commitc58483ea9cc4ef60380a13f19c9524b1aaa2681a (patch)
treeef3699597f72d85cecd31f5f215f7f846affd68b /PKGBUILD
downloadaur-python-opencc.tar.gz
init python opencc package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5688a018ed75
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Nicholas Yim <nickyim05@gmail.com>
+
+pkgname=python-opencc
+pkgver=0.2
+pkgrel=1
+pkgdesc="An OpenCC converter for Python."
+arch=('x86_64')
+depends=('opencc')
+makedepends=('python-setuptools')
+url="https://github.com/lepture/opencc-python"
+license=('Apache')
+options=(!emptydirs)
+source=(https://github.com/lepture/opencc-python/archive/v$pkgver.tar.gz)
+sha256sums=('6c581666853f8267a7d9f97ecf6ccc80d05e47c8a9f5ea8428c675166f3d76c1')
+
+build() {
+ cd "$srcdir/opencc-python-$pkgver"
+
+ msg2 'Building...'
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/opencc-python-$pkgver"
+
+ msg2 'Installing...'
+ python setup.py install --root="$pkgdir" --optimize=1
+}