summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2022-11-03 09:54:56 +0100
committerMichel Zou2022-11-03 09:54:56 +0100
commit69615cc53b91c7efa337149d781101e1bfdaf709 (patch)
treeaf37dfb7a858cefdd95403ce56c5793bbc6f7805 /PKGBUILD
downloadaur-python-otfmi.tar.gz
0.15
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f8ba673a3d13
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname=python-otfmi
+pkgver=0.15
+pkgrel=1
+pkgdesc="FMI models manipulation module"
+license=('LGPL')
+arch=('any')
+url="http://www.openturns.org/"
+depends=('openturns')
+makedepends=('python-setuptools')
+source=("https://github.com/openturns/otfmi/archive/v$pkgver.tar.gz")
+sha256sums=('18f481a20d08aa0b6ad85b21a27d43a1b13242696568da7f81ed3304b3be0f6e')
+
+build() {
+ cd otfmi-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd otfmi-$pkgver
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}
+