diff options
author | Alexander Bocken | 2024-12-23 09:21:11 +0100 |
---|---|---|
committer | Alexander Bocken | 2024-12-23 09:21:11 +0100 |
commit | 5c1cea3c728170d1340f9026152af89378e6e60f (patch) | |
tree | 93a6931a2a74fb24506709d86dac9ec3c4affdb9 /PKGBUILD | |
parent | 6f1800b69f8cfb53c08cdd8d73b8ea7535d15f8b (diff) | |
download | aur-python-pathpy3.tar.gz |
force reubild against python 3.13
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 13 |
1 files changed, 12 insertions, 1 deletions
@@ -3,7 +3,7 @@ _name=pathpy3 pkgname=python-$_name pkgver=3.0.0a2 -pkgrel=1 +pkgrel=2 pkgdesc="pathpy: path data analysis" arch=('any') url="https://www.pathpy.net" @@ -26,6 +26,17 @@ build() { echo "Fixing $file" sed -i 's/from singledispatchmethod/from functools/' "$file" done + + # remove deprecated sphinx calls for documentation creation (not used) + for file in $(grep -r 'add_stylesheet' ./ | cut -d: -f1); do + echo "Fixing $file" + sed -i 's/add_stylesheet/add_css_file/' "$file" + done + for file in $(grep -r 'add_javascript' ./ | cut -d: -f1); do + echo "Fixing $file" + sed -i 's/add_javascript/add_js_file/' "$file" + done + python -m build --wheel --no-isolation -x } package() { |