summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlphaJack2024-02-09 13:11:01 +0100
committerAlphaJack2024-02-09 13:11:01 +0100
commitdca27e2fa3ee2dcca187af669f0b44d6a4cfad88 (patch)
treea79248a3325abb9a2a56bbf34aaae68fd3246be9 /PKGBUILD
downloadaur-python-pgsanity.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d491d8b82869
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: AlphaJack <alphajack at tuta dot io>
+
+pkgname="python-pgsanity"
+_name="${pkgname#python-}"
+pkgver=0.2.9
+pkgrel=1
+pkgdesc="Check syntax of sql for PostgreSQL"
+arch=(any)
+url="https://github.com/markdrago/pgsanity"
+license=('MIT')
+depends=()
+makedepends=("python-build" "python-installer" "python-setuptools" "python-wheel")
+source=("https://pypi.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz")
+b2sums=('d1ae0d2f08f2fd5188882fabc68f09f532230e9689602ad195dfe0cf39172760c7e26c1989489a60cf03ceeec4b75b367bfcbcc99f0c9e6ea381000b4af3c41a')
+options=("!strip")
+
+build(){
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
+package(){
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}