summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSanskritFritz2020-11-22 19:55:58 +0100
committerSanskritFritz2020-11-22 19:55:58 +0100
commitc031847b05f84a90b1aef234c209c98a491318e6 (patch)
tree8c07f0a47478a388a1ccf113f1910ffa74c7f695 /PKGBUILD
downloadaur-python-pick.tar.gz
Upstream version 1.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a8f1f6f323a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: SanskritFritz (gmail)
+
+pkgname=python-pick
+_name=${pkgname#python-}
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Python library to create interactive selection list in the terminal"
+arch=('any')
+url="https://github.com/wong2/pick"
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools')
+source=("https://github.com/wong2/pick/archive/v$pkgver.tar.gz")
+md5sums=('937254e385c8a33bf511741974942eb5')
+
+build() {
+ cd $_name-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd $_name-$pkgver
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+}