summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGabriel Souza Franco2024-04-27 12:22:04 -0300
committerGabriel Souza Franco2024-04-27 12:22:04 -0300
commit0c498307d123bd91c312116b7eabdf70b4fcac17 (patch)
tree80836334fefbb0198f8235d929ae37ed830f252a /PKGBUILD
parent7cef4eaa85a0677fcb67736bd64b7e637c9bccba (diff)
downloadaur-python-powerline-git.tar.gz
Migrate to python-build, rebuild for Python 3.12
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3dfde8516507..e1303208d6f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=python-powerline-git
pkgdesc='The ultimate statusline/prompt utility'
-pkgver=2.8.3+2+g833f30e8
+pkgver=2.8.3+6+ga34abe32
pkgrel=1
epoch=1
url='https://github.com/powerline/powerline'
@@ -13,7 +13,7 @@ license=('MIT')
arch=('i686' 'x86_64')
depends=('python>=3.2')
conflicts=('powerline2' 'powerline' 'python2-powerline-git' 'otf-powerline-symbols-git')
-makedepends=('git' 'python-setuptools' 'python-sphinx')
+makedepends=('git' 'python-build' 'python-installer' 'python-setuptools' 'python-sphinx')
optdepends=('python-psutil: improved system information'
'python-pygit2: improved git support'
'python-hglib: improved mercurial support'
@@ -33,7 +33,7 @@ pkgver() {
build() {
cd powerline
- python setup.py build
+ python -m build --no-isolation --wheel
cd docs
make man
@@ -41,7 +41,7 @@ build() {
package_python-powerline-git() {
cd powerline
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer dist/*.whl --destdir="$pkgdir"
# Fonts
install -dm755 "$pkgdir/etc/fonts/conf.d"