summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohnathan Jenkins2016-07-25 15:34:59 -0700
committerJohnathan Jenkins2016-07-25 15:34:59 -0700
commit566920018d805a73d33a5b2a9d863af736b46e65 (patch)
treec59cde85b83fc53cf187660ee9679e0eee6e7d0e /PKGBUILD
downloadaur-python-prawcore-git.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5f0d76bbebf1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Johnathan Jenkins <twodopeshaggy@gmail.com>
+
+
+pkgname=python-prawcore-git
+pkgver=.r128.gdb0fdb9
+pkgrel=1
+pkgdesc="Low-level communication layer for PRAW 4+."
+arch=('any')
+url="https://github.com/praw-dev/prawcore"
+license=('GPL3')
+depends=('python-decorator' 'python-six' 'python-requests' )
+makedepends=('git' 'python-setuptools')
+provides=('python-prawcore')
+conflicts=('python-prawcore')
+source=(${pkgname}::'git+https://github.com/praw-dev/prawcore.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ printf "%s.r%s.g%s" "$(grep __version__ praw/const.py | head -1 | cut -d"'" -f2)" \
+ "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+package() {
+ cd "${pkgname}"
+ python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
+}