summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNathan Owens2020-05-06 21:16:54 -0500
committerNathan Owens2020-05-06 21:17:12 -0500
commit97594b82f422e2a928a7de36a7e546e6d3ef2fdb (patch)
tree8835e7d933398e61465896530ede0e5ac05ec651 /PKGBUILD
parentb1d4aff034a24cef41808a00d7ea397f06af27e1 (diff)
downloadaur-python-pybrain.tar.gz
Dead project it seems, so import last fixes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 117d89aa291f..19768736c0dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,22 @@
pkgname=('python-pybrain')
pkgver=0.3.3
-pkgrel=1
+pkgrel=2
pkgdesc='A modular Machine Learning Library for Python'
arch=('any')
url='http://pybrain.org/'
license=('BSD')
depends=('python' 'python-numpy' 'python-scipy')
makedepends=('python-setuptools' 'git')
-source=("git+https://github.com/pybrain/pybrain#tag=$pkgver")
-sha512sums=('SKIP')
+source=("git+https://github.com/pybrain/pybrain#tag=$pkgver"
+ "several.patch::https://github.com/pybrain/pybrain/compare/0.3.3...master.patch")
+sha512sums=('SKIP'
+ 'f3ae1ecd6fa5b119a97185ebba2f9f8a3f742ae2f66e751d42314457680ee08e63c3c4fb3a18df051ab1c1224794c0f651f42a5c5bb9d17f1e484bb4fbd1905b')
+
+prepare() {
+ cd pybrain
+ git apply --stat "$srcdir"/several.patch
+}
build() {
cd pybrain