summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartin Diehl2023-10-10 12:56:32 +0200
committerMartin Diehl2023-10-10 12:56:32 +0200
commitb517fbdc86cb143d7abd8d12997e65aec2267529 (patch)
tree4bd074f0bc16cb8e35ef87ed536af0fb2639c8d6 /PKGBUILD
parent507e261f07c14ec1a7e588f92f02e0922e70bc7a (diff)
downloadaur-python-pycifrw.tar.gz
modern build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6008c5af01e3..c1e4ada13e7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Ross Whitfield <whitfieldre@ornl.gov>
pkgver=4.4.5
-pkgrel=3
+pkgrel=4
pkgname='python-pycifrw'
_name='PyCifRW'
pkgdesc='CIF/STAR file support for Python'
@@ -16,11 +16,11 @@ sha512sums=('f1484789fc9f32b7fc9f2c0ab176992a571e4c5bf8d7794e0f1c1c0a7d1c8271133
build() {
cd "$_name-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$_name-$pkgver"
- python setup.py install --skip-build --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}