summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohannes Schlatow2023-07-05 10:43:39 +0200
committerJohannes Schlatow2023-07-05 10:43:39 +0200
commit324a45f44d88c7a5e64958d296ddaf2a7be5a6ee (patch)
treef20d40b80395e0f54514e67f5d38826130f8904f /PKGBUILD
parentd63d842304ad73d559bac8d324c44832a52ada70 (diff)
downloadaur-python-pycpa-git.tar.gz
update PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c94d6d9750fd..e8d42e4cbde9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,13 @@
_pkgname=python-pycpa
pkgname=$_pkgname-git
-pkgver=20210311
+pkgver=r512.824e794
pkgrel=1
pkgdesc="Pragmatic Python implementation of Compositional Performance Analysis (aka the SymTA/S approach provided by Symtavision) used for research in worst-case timing analysis."
arch=('any')
-makedepends=('git')
+makedepends=('git' 'python-setuptools')
replaces=('python-pycpa-hg')
-depends=('python' 'python-matplotlib' 'python-pygraphviz' 'python-setuptools')
-optdepends=('python2-twisted: for RPC interface'
- 'python2-simpy: for simulation module')
+depends=('python' 'python-matplotlib' 'python-pygraphviz')
provides=('python-pycpa')
url="https://github.com/IDA-TUBS/pycpa.git"
license=('MIT')
@@ -18,6 +16,11 @@ license=('MIT')
source=("git+https://github.com/IDA-TUBS/pycpa.git")
md5sums=("SKIP")
+pkgver() {
+ cd "${srcdir}/pycpa"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+}
+
build() {
cd ${srcdir}/pycpa
python setup.py build