summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2023-06-13 19:26:04 +0200
committerFabioLolix2023-06-13 19:26:04 +0200
commit55ee7c7bd795e0cd1d4460b85b738ef1fa3f2633 (patch)
tree3200d9534b24ac6e0105864a6eeb5ade27fb881f /PKGBUILD
parent4b15510c3a9a290ee580b0adb476f40fb176e72a (diff)
downloadaur-python-pydbus-git.tar.gz
change source, remove python2 version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 18 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 945057ca9267..14ab47ac0510 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,26 @@
-# Maintainer: Janusz Lewandowski <lew21@xtreeme.org>
-pkgname=('python-pydbus-git'
- 'python2-pydbus-git')
-pkgver=0.5.1.r0.1b58124
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Janusz Lewandowski <lew21@xtreeme.org>
+
+pkgname=python-pydbus-git
+pkgver=0.6.0.r17.77fc029
pkgrel=1
pkgdesc="Pythonic DBus library"
-arch=("any")
-url="https://github.com/LEW21/pydbus"
-license=('LGPL')
-makedepends=('git' 'python-setuptools' 'python2-setuptools')
-source=('pydbus::git+https://github.com/LEW21/pydbus.git')
-md5sums=('SKIP')
+arch=(any)
+url="https://github.com/openEuler-BaseService/pydbus"
+license=(LGPL2.1)
+depends=(python python-gobject gobject-introspection-runtime)
+makedepends=(git python-setuptools)
+provides=(python-pydbus)
+conflicts=(python-pydbus)
+source=("git+https://github.com/openEuler-BaseService/pydbus.git")
+sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/pydbus"
- printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g;s/v//')"
+ cd "$srcdir/pydbus"
+ git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g;s/v//'
}
package_python-pydbus-git() {
- depends=('python' 'python-gobject')
- provides=("${pkgname%-git}")
- conflicts=("${pkgname%-git}")
- cd "$srcdir/pydbus"
- python setup.py install --root="$pkgdir/" --optimize=1
-}
-
-package_python2-pydbus-git() {
- depends=('python2' 'python2-gobject')
- provides=("${pkgname%-git}")
- conflicts=("${pkgname%-git}")
- cd "$srcdir/pydbus"
- python2 setup.py install --root="$pkgdir/" --optimize=1
+ cd "$srcdir/pydbus"
+ python setup.py install --root="$pkgdir/" --optimize=1
}