summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJose Riha2019-07-11 15:42:38 +0200
committerJose Riha2019-07-11 15:42:44 +0200
commit27e8d0b8d61db37f5d00d5db81a377baff97e731 (patch)
tree288475a1e0c6f31ccad71f5b5eab77a7d72a3c34 /PKGBUILD
downloadaur-27e8d0b8d61db37f5d00d5db81a377baff97e731.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5566178f2f95
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Jose Riha <jose1711 gmail com>
+
+pkgname=python-pygatt
+_module=pygatt
+pkgver=4.0.3
+pkgrel=1
+pkgdesc="Python Bluetooth LE (Low Energy) and GATT Library"
+url="https://github.com/peplin/pygatt"
+depends=('python' 'python-pexpect' 'python-pyserial')
+makedepends=('python-setuptools')
+license=('APACHE')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+sha256sums=('b1db8e294fc9c68f4dee66e7e2bdde3240c18c2495237059b83f3e7ca9897466')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}