summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Laß2023-07-30 11:37:53 +0200
committerMichael Laß2023-07-30 11:41:57 +0200
commitbf57e4583940b272ede0380cc633f6201e7963cb (patch)
tree02d6a1a00bc71c6015dafbabf25022b5b3bc7714 /PKGBUILD
parentb5316eabbae57b6f0c630cd5355f1944d7235ebd (diff)
downloadaur-bf57e4583940b272ede0380cc633f6201e7963cb.tar.gz
Adopt, fix by removing enum-compat from setup.py
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 20 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d08511c9363d..7b395e97cc30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,29 @@
-# Maintainer: Jose Riha <jose1711 gmail com>
-# Co-contributor: Andrea Pascal <andrea@anodium.net>
+# Maintainer: Michael Lass <bevan@bi-co.net>
+# Contributor: Jose Riha <jose1711 gmail com>
+# Contributor: Andrea Pascal <andrea@anodium.net>
+
+# This PKGBUILD is maintained on github:
+# https://github.com/michaellass/AUR
pkgname=python-pygatt
_module=pygatt
pkgver=4.0.5
-pkgrel=2
+pkgrel=3
pkgdesc="Python Bluetooth LE (Low Energy) and GATT Library"
url="https://github.com/peplin/pygatt"
depends=('python-pexpect' 'python-pyserial')
-license=('APACHE')
+license=('custom:partly Apache, partly MIT')
arch=('any')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
-sha256sums=('7f4e0ec72f03533a3ef5fdd532f08d30ab7149213495e531d0f6580e9fcb1a7d')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz"
+ 0001-Remove-dependency-on-enum-compat.patch)
+sha256sums=('7f4e0ec72f03533a3ef5fdd532f08d30ab7149213495e531d0f6580e9fcb1a7d'
+ '1485111d418ac0812751426bbbec76ef56f8d79b7740f41009f7f6cb7f2a1e1a')
+
+prepare() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ patch -p1 < "${srcdir}/0001-Remove-dependency-on-enum-compat.patch"
+}
build() {
cd "${srcdir}/${_module}-${pkgver}"
@@ -24,7 +35,9 @@ check() {
python setup.py check -m -s
}
-package_python-pygatt() {
+package() {
cd "${srcdir}/${_module}-${pkgver}"
+
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}