summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorShanti Bouchez-Mongardé2015-09-22 23:21:29 +0200
committerShanti Bouchez-Mongardé2015-09-22 23:23:05 +0200
commit80c59127968be56df9c1b548b5df41290a521efe (patch)
tree91b74bcc40a09c03d2b49d4c11c556106796b792 /PKGBUILD
downloadaur-python-pylibscrypt-git.tar.gz
python-pylibscrypt
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..316a4bbbb2b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgname=python-pylibscrypt-git
+pkgrel=1
+pkgver=v1.4.0.r37.g6fd3012
+arch=(any)
+depends=(python)
+source=(python-pylibscrypt-git::git://github.com/jvarho/pylibscrypt.git)
+md5sums=(SKIP)
+provides=(python-pylibscrypt)
+conflicts=(python-pylibscrypt)
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build(){
+ cd "$srcdir/$pkgname"
+ python setup.py build
+}
+
+package(){
+ cd "$srcdir/$pkgname"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}