summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJames Barnett2016-12-31 11:24:27 -0600
committerJames Barnett2016-12-31 11:24:27 -0600
commit88da4df56ee308e1e8c0e67b538e499dc295af3c (patch)
treed794db117eb81297850b05e1f1568f1028451e72 /PKGBUILD
downloadaur-python-pymbar-git.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e5fb8155c326
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer James W. Barnett <jbarnet4 at tulane dot edu>
+pkgname=python-pymbar-git
+pkgver=r453.dc0fd3f
+pkgrel=1
+pkgdesc="Python implementation of the multistate Bennett acceptance ratio (MBAR) method for estimating expectations and free energy differences. "
+arch=('i686' 'x86_64')
+url="https://github.com/choderalab/pymbar"
+license=('LGPL')
+depends=('python' 'python-numpy' 'python-scipy' 'python-six')
+makedepends=('git' 'python-nose' 'python-statsmodels')
+source=('git://github.com/choderalab/pymbar.git')
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/pymbar"
+ git describe --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/pymbar"
+ python setup.py build
+}
+
+check() {
+ cd "$srcdir/pymbar"
+ nosetests ./pymbar
+}
+
+package() {
+ cd "$srcdir/pymbar"
+ python setup.py install -O2 --root=$pkgdir || return 1
+}