summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFilip Gralinski2022-01-22 13:18:21 +0100
committerFilip Gralinski2022-01-22 13:18:21 +0100
commit3a0dcce8db830243f60d416c55a9fe2e1bcf2106 (patch)
tree1d90cbb780e3d2248c8ac28a9f77705ed677f12c /PKGBUILD
downloadaur-python-pyminder.tar.gz
Init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f215d9036a06
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Filip Gralinski <filipg@amu.edu.pl>
+
+_name=pyminder
+pkgname=python-${_name}
+pkgver=1.1.1
+pkgrel=1
+pkgdesc="Beeminder power tools library"
+arch=('any')
+url="https://github.com/narthur/pyminder"
+license=('MIT')
+depends=('python-requests' 'python-natlibpy')
+source=("https://files.pythonhosted.org/packages/45/cf/0083522f5134404ac693c62f496fc7d2e82f8d0a478729236c31b3e1b065/${_name}-${pkgver}.tar.gz")
+sha256sums=('031a652d8782a23adb2be3dbe7e98741ede600a45c68b2b22d6dcc8d51425067')
+
+build() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="${pkgdir}"
+}