summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLev Levitsky2023-09-04 11:46:27 +0200
committerLev Levitsky2023-09-04 11:46:27 +0200
commit3dd4dacf2ce4b800568213e1f358526ca691b385 (patch)
tree65ab6287032c5fc71d5f7fab1a28a705d4aeb394 /PKGBUILD
parent69d2a31397836cf9df7934e2e26090b053141e8b (diff)
downloadaur-python-pynumpress.tar.gz
v0.0.8
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a1e00c4df5e5..c6aa936674f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,26 @@
pkgname=python-pynumpress
_bname=pynumpress
-pkgver=0.0.6
+pkgver=0.0.8
pkgrel=1
pkgdesc="A more pythonic wrapper around the MSNumpress library for mass spectrometry numerical data compression"
arch=('x86_64')
url="https://github.com/mobiusklein/pynumpress"
license=('Apache')
-depends=('python-numpy')
-makedepends=('cython')
+depends=(python-numpy)
+makedepends=(python-build python-installer python-wheel cython python-oldest-supported-numpy)
options=(!emptydirs)
source=("https://pypi.io/packages/source/p/${_bname}/${_bname}-${pkgver}.tar.gz")
-sha256sums=('a5d4633ad48cb5657b38c518abe320094bcf1465190732919622e1ab9a906f56')
+sha256sums=('8c449687d6924a71ee3d20331ea1a6e9f223ee82682a3b6f6eba5da26c46d591')
+
+build() {
+ cd "$srcdir/${_bname}-$pkgver"
+ python -m build --wheel --no-isolation
+}
package() {
cd "$srcdir/${_bname}-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}
# vim:set ts=2 sw=2 et: