summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2021-10-06 00:05:50 -0500
committerLuis Martinez2021-10-06 00:05:50 -0500
commit538f0eeda558fb0bf4a71eeea7b00d56a0d0e7f8 (patch)
treed52bfa6a599b37cdc89d11325a045aec8b898de5 /PKGBUILD
parent18f3d58be2816b84e11fe507e8e289dca512ac49 (diff)
downloadaur-python-pyral.tar.gz
update to 1.5.2
package cleaned up according to Python packaging guidelines
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 20 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 07713a5a0a16..8ba004e91854 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,29 @@
-# Maintainer: juantascon <juantascon.aur@horlux.org>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: juantascon <juantascon.aur@horlux.org>
pkgname=python-pyral
-_pkgname=pyral
-pkgver=1.3.1
+pkgver=1.5.2
pkgrel=1
pkgdesc="Python Toolkit for Rally"
arch=('any')
url="https://github.com/RallyTools/RallyRestToolkitForPython"
-license=("PYRAL")
-depends=('python' 'python-requests')
-source=("https://github.com/RallyTools/RallyRestToolkitForPython/releases/download/v${pkgver}/${_pkgname}-${pkgver}.tar.gz")
-sha256sums=('1f3ee31e78e5a556370c2e1bb950cef57ae7b82033d72ad996f97b149a51e5c7')
+license=("BSD")
+depends=('python>=3.6' 'python-requests>=2.25.1' 'python-six')
+makedepends=('python-setuptools' 'python-sphinx' 'python-sphinx_rtd_theme')
+changelog=VERSIONS
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/p/pyral/pyral-$pkgver.tar.gz")
+sha256sums=('341575f25c2d208b11da0ee07919e863e464164a1eae3d6b87f183ce57c698f5')
+
+build() {
+ cd "pyral-$pkgver"
+ python setup.py build
+ cd doc
+ make man
+}
package() {
- cd ${srcdir}/${_pkgname}-${pkgver}/
- python setup.py install --root ${pkgdir}
+ cd "pyral-$pkgver"
+ PYTHONHASHSEED=0 python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm 644 doc/build/man/pyral.1 -t "$pkgdir/usr/share/man/man1/"
}