diff options
author | Martin Larralde | 2025-03-04 01:57:55 +0100 |
---|---|---|
committer | Martin Larralde | 2025-03-04 01:57:55 +0100 |
commit | 8b5e08763dafb9f036bba0251a97a81cbd407037 (patch) | |
tree | 75df3a88b1dea72160c65f58e0e9999a9c33979e /PKGBUILD | |
parent | 5c2a572906bc0f1015b65c5d95e14dff56e3e9af (diff) | |
download | aur-python-pyrodigal.tar.gz |
Release v3.6.3-post1
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 15 |
1 files changed, 8 insertions, 7 deletions
@@ -3,7 +3,8 @@ _name=pyrodigal pkgname=python-${_name} pkgver=3.6.3 -pkgrel=1 +_extraver=".post1" +pkgrel=2 pkgdesc="Cython bindings to Prodigal, an ORF finder for genomes and metagenomes" url="https://github.com/althonos/pyrodigal" arch=('i686' 'pentium4' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64') @@ -13,18 +14,18 @@ makedepends=('cython' 'python-build' 'python-installer' 'cmake' 'ninja' 'python- optdepends=('python-isal: fast gzip decompression support' 'python-lz4: lz4 decompression support' 'python-zstandard: zstd decompression support') -source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz") -sha256sums=(3e226f743c960d4d30c46ae6868aff7e2a6b98f8d837cfbd2637568569b21f78) +source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-${pkgver}${_extraver}.tar.gz") +sha256sums=(f42e8df8062b08796f2e92902800584c0b62ead765945594d06224e0b6c2b96c) build() { - cd "${srcdir}/${_name}-${pkgver}" + cd "${srcdir}/${_name}-${pkgver}${_extraver}" python -m build --wheel --no-isolation --skip-dependency-check } check() { local abitag=$(python -c 'import sys; print(*sys.version_info[:2], sep="")') local machine=$(python -c 'import platform; print(platform.machine())') - whl="${srcdir}/${_name}-${pkgver}/dist/${_name}-${pkgver}-cp${abitag}-cp${abitag}-linux_${machine}.whl" + whl="${srcdir}/${_name}-${pkgver}${_extraver}/dist/${_name}-${pkgver}${_extraver}-cp${abitag}-cp${abitag}-linux_${machine}.whl" python -m venv --symlinks --system-site-packages "${srcdir}/env" source "${srcdir}/env/bin/activate" @@ -36,8 +37,8 @@ check() { package() { local abitag=$(python -c 'import sys; print(*sys.version_info[:2], sep="")') local machine=$(python -c 'import platform; print(platform.machine())') - whl="${srcdir}/${_name}-${pkgver}/dist/${_name}-${pkgver}-cp${abitag}-cp${abitag}-linux_${machine}.whl" + whl="${srcdir}/${_name}-${pkgver}${_extraver}/dist/${_name}-${pkgver}${_extraver}-cp${abitag}-cp${abitag}-linux_${machine}.whl" python -m installer --prefix="${pkgdir}/usr" "$whl" - install -Dm644 ${srcdir}/${_name}-${pkgver}/COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING" + install -Dm644 ${srcdir}/${_name}-${pkgver}${_extraver}/COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING" } |