summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichal Wojdyla2020-03-03 14:58:59 +0100
committerMichal Wojdyla2020-03-03 14:58:59 +0100
commitf89bc9f08c4a327561ab30a10571a519ce40937a (patch)
treef9a556f678c10fe772b34d81418610010fb27732 /PKGBUILD
downloadaur-python-pysensors.tar.gz
created aur package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8611188a5b33
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Michal Wojdyla <micwoj9292 at gmail dot com>
+
+_pkgname=PySensors
+pkgname=python-pysensors
+pkgver=0.0.4
+pkgrel=1
+pkgdesc="Python bindings to libsensors (via ctypes)"
+arch=('any')
+depends=('python' 'lm_sensors')
+makedepends=('python-setuptools')
+url="https://bitbucket.org/blackjack/pysensors/"
+license=('Apache' 'MIT')
+options=(!emptydirs)
+source=("https://pypi.python.org/packages/source/P/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('beb0def410d29ee46fe196a7811124772abf84cbe3a0d8b01d80b81fba31dae5')
+
+build() {
+ cd "$srcdir/${_pkgname}-$pkgver"
+
+ msg 'Building...'
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/${_pkgname}-$pkgver"
+
+ msg 'Installing...'
+ python setup.py install --root="$pkgdir" --optimize=1
+} \ No newline at end of file