summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichal Wojdyla2021-08-23 20:18:35 +0200
committerMichal Wojdyla2021-08-23 20:18:35 +0200
commitdf74e2a4dc16a2b3978df8feb3a151db92964ff9 (patch)
treeb972e3862b0d0525814bf2e3501a0f5aa16d971a /PKGBUILD
parentcad93f70e87993b84ff4ef9eb220596f95791394 (diff)
downloadaur-python-pysynth-git.tar.gz
update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 899fc0ceb9ae..05cd90f8fe6d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=python-pysynth-git
_pkgname=PySynth
-pkgver=20170611.3441e61
+pkgver=20200225.938f80a
pkgrel=1
pkgdesc="A simple music synthesizer for Python 3"
arch=(any)
@@ -11,7 +11,7 @@ url="http://mdoege.github.io/PySynth/"
license=('GPL')
depends=('python-numpy')
makedepends=('git')
-source=("git://github.com/mdoege/PySynth.git")
+source=("git+https://github.com/mdoege/PySynth.git")
md5sums=('SKIP')
pkgver() {
@@ -19,8 +19,12 @@ pkgver() {
git log -1 --format='%cd.%h' --date=short | tr -d -
}
-package() {
+build() {
cd "${srcdir}/${_pkgname}"
- python setup.py install --root="$pkgdir"
+ python setup.py build
}
+package() {
+ cd "${srcdir}/${_pkgname}"
+ python setup.py install --root="$pkgdir" --optimize=1
+}