diff options
author | Carlos Aznarán | 2024-01-31 21:07:54 -0500 |
---|---|---|
committer | Carlos Aznarán | 2024-01-31 21:07:54 -0500 |
commit | 483e62b721b7349ff1dfb163e416a921a435e605 (patch) | |
tree | 5c19813b9aec8af01bb3bf26291c6c917f35beef /PKGBUILD | |
parent | 36749c1e6205683ff71e107ff1fc54c24a0c362d (diff) | |
download | aur-python-pytest-base-url.tar.gz |
Bump version to 2.1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 5 |
1 files changed, 3 insertions, 2 deletions
@@ -8,13 +8,14 @@ arch=(any) url="https://github.com/pytest-dev/${_base}" license=(MPL2) depends=(python-pytest python-requests) -makedepends=(python-build python-installer python-poetry-core) +makedepends=(python-build python-installer python-hatch-vcs python-wheel) checkdepends=(python-pytest-localserver) source=(${_base}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz) sha512sums=('d5747f7ab7f7995f3b822b9770f9194132f1fff5636c5deaf24fae4d5be054a3eb6512ac09b1e9fc5a6d93d31ab05f9ee4df76f1c2d00c5cb200b81ef2750b43') build() { cd ${_base}-${pkgver} + export SETUPTOOLS_SCM_PRETEND_VERSION=${pkgver} python -m build --wheel --skip-dependency-check --no-isolation } @@ -22,7 +23,7 @@ check() { cd ${_base}-${pkgver} python -m venv --system-site-packages test-env test-env/bin/python -m installer dist/*.whl - test-env/bin/python -m pytest tests + test-env/bin/python -m pytest tests -k 'not metadata and not url_fails' } package() { |