summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-06-01 09:20:55 -0500
committerCarlos Aznarán Laos2022-06-01 09:20:55 -0500
commit838c1ae50fcdc3927420f1240542bad28b8ace7d (patch)
tree9cce2e4ea2b34edd55e4ad073ed093c7124d9634 /PKGBUILD
parenteeb544116c91b92d45c0d149583f6093ba4c54b2 (diff)
downloadaur-python-pythontexfigures.tar.gz
Update license
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 25 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 325464d11279..732e97ba8c1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,35 @@
-# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
-
-_pkgname='pythontexfigures'
-pkgname="python-${_pkgname}"
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
+_base=pythontexfigures
+pkgname=python-${_base}
+pkgdesc="Embed matplotlib figures into LaTeX documents using PythonTeX"
pkgver=0.2.0
-pkgrel=2
+pkgrel=3
+arch=(any)
_commit_version='55bf83a495cf7b4f0d408fa834f430e3fcd5d95f'
-
-pkgdesc='Embed matplotlib figures into LaTeX documents using PythonTeX'
-arch=('any')
-url='https://github.com/mje-nz/pythontexfigures'
-_url_pypi='https://pypi.org/project/pythontexfigures'
-license=('BSD')
-depends=('python-matplotlib' 'python-pygments')
-makedepends=('git' 'python-setuptools')
-source=("${pkgname}::git+${url}.git#commit=${_commit_version}")
-sha256sums=('SKIP')
+url="https://github.com/mje-nz/${_base}"
+license=('custom:BSD-3-clause')
+depends=(python-matplotlib python-pygments)
+makedepends=(git python-setuptools)
+# checkdepends=(python-pytest texlive-pictures fvextra) # python-seaborn
+source=("git+${url}.git#commit=${_commit_version}")
+sha512sums=('SKIP')
build() {
- cd "${pkgname}"
+ cd ${_base}
python setup.py build
}
+# check() {
+# cd ${_base}
+# # https://github.com/mje-nz/pythontexfigures/blob/master/.circleci/config.yml#L23
+# python -m pytest
+# }
+
package() {
- cd "${pkgname}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -Dvm644 'Readme.md' -t "${pkgdir}/usr/share/doc/${pkgname}"
- install -Dvm644 'LICENSE' -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ cd ${_base}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm 644 Readme.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
-
-# vim: ts=2 sw=2 et: