summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartin Diehl2025-01-03 14:12:07 +0100
committerMartin Diehl2025-01-03 14:12:07 +0100
commit71e456d93df367d5aab480a2f0dcb3457848a084 (patch)
treeb729b253c4fa2602e184be6796e81e058dea24cf /PKGBUILD
parent7b310ece6c8590f573849e17ebae59dbc95e1afa (diff)
downloadaur-python-pyvista.tar.gz
license file needed for MIT
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fadc2773d8b5..009968bf95d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,25 @@
pkgname=python-pyvista
pkgver=0.44.2
-pkgrel=3
+pkgrel=4
pkgdesc='3D plotting and mesh analysis through a streamlined interface for VTK'
arch=(any)
-url='https://www.pyvista.org'
-license=('MIT')
-depends=('python-numpy' 'python-pillow' 'python-pooch' 'python-scooby' 'vtk' 'python-matplotlib')
-makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools')
-optdepends=('python-meshio' 'xorg-server-xvfb' 'python-imageio')
+url=https://www.pyvista.org
+license=(MIT)
+depends=(python-numpy python-pillow python-pooch python-scooby vtk python-matplotlib)
+optdepends=(python-meshio xorg-server-xvfb python-imageio)
+makedepends=(python-build python-installer python-wheel python-setuptools)
_name=${pkgname#python-}
-source=("https://github.com/pyvista/pyvista/archive/v${pkgver}/pyvista-${pkgver}.tar.gz")
+source=(https://github.com/pyvista/${_name}/archive/v${pkgver}/${_name}-${pkgver}.tar.gz)
sha512sums=('82a10149dcb47981eb66fa19ccb202a11b5999488b8e69e20913e0e1f11a35bc27e96cd8b983bca49edeaf443d497713a30a2b72f1f82bbb62374d79855a877f')
build() {
- cd "$_name-$pkgver"
+ cd ${_name}-${pkgver}
python -m build --wheel --no-isolation
}
package() {
- cd "$_name-$pkgver"
- python -m installer --destdir="$pkgdir" dist/*.whl
+ cd ${_name}-${pkgver}
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm644 LICENSE -t "${pkgdir}"/usr/share/licenses/${pkgname}
}