summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-08-24 00:03:24 -0500
committerCarlos Aznarán Laos2023-08-24 00:03:24 -0500
commitec2cd91cdfb2051f02ae7d5e8c60d99789347d7a (patch)
treefc3f2f303ba717f051190d6224d51e1963476592 /PKGBUILD
parent697d8aabb129eb4683916bfad9d9af65391dd34f (diff)
downloadaur-python-pyvoro-mmalahe.tar.gz
Bump version to 1.3.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 16 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4fb7d2f64126..de6ac02a963b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,30 @@
# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
-_base=pyvoro
-pkgname=python-${_base}-mmalahe
+_base=pyvoro-mmalahe
+pkgname=python-${_base}
pkgdesc="2D and 3D Voronoi tessellations: a python entry point for the voro++ library"
-_gitcommit=30645a24c21e1a2a88f88834d15d73de3a6dccf1
-pkgver=1.3.3
-pkgrel=3
-arch=('x86_64')
-url="https://github.com/mmalahe/${_base}"
+pkgver=1.3.4
+pkgrel=1
+arch=(x86_64)
+url="https://github.com/mmalahe/${_base%%-*}"
license=('custom')
depends=(python)
-makedepends=(python-build python-installer python-setuptools python-wheel cython git)
-source=("git+${url}.git#commit=${_gitcommit}")
-sha512sums=('SKIP')
-
-prepare() {
- sed -i 's/-file/_file/' ${_base}/setup.cfg
- cd ${_base}/${_base}
- cython voroplusplus.pyx --cplus
-}
+makedepends=(python-build python-installer python-setuptools python-wheel)
+source=(https://pypi.org/packages/source/${_base::1}/${_base}/${_base}-${pkgver}.tar.gz)
+sha512sums=('05bcf82e12610a56378832e90505f0317c907b6b00212559936e7d76df3787248bf054e64608641e9c66d77a25b26076c05e1e8399ab0788970622fb09f9bb75')
build() {
- cd ${_base}
+ cd ${_base}-${pkgver}
python -m build --wheel --skip-dependency-check --no-isolation
}
-check() {
- cd ${_base}
- local _pyversion=$(python -c "import sys; print(f'{sys.version_info.major}.{sys.version_info.minor}')")
- PYTHONPATH="${PWD}/build/lib.linux-${CARCH}-${pyversion}/${_base}" python setup.py test
-}
+# check() {
+# cd ${_base}-${pkgver}
+# local _pyversion=$(python -c "import sys; print(f'{sys.version_info.major}.{sys.version_info.minor}')")
+# PYTHONPATH="${PWD}/build/lib.linux-${CARCH}-${pyversion}/${_base}" python setup.py test
+# }
package() {
- cd ${_base}
+ cd ${_base}-${pkgver}
PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm 644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
}