summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrey Christoforo2020-11-01 13:08:18 +0100
committerGrey Christoforo2020-11-01 13:08:18 +0100
commit4b1738b5d2e22b51043692a24c3c235006473221 (patch)
treef0704689c1870441a2cafb4e8037a7e16bf6bd19 /PKGBUILD
parente30336f5665988101dd1a3298dbacef95dfb03bf (diff)
downloadaur-python-qiime2.tar.gz
bump version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 89de5475c642..25148158517a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,25 @@
# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
pkgname=python-qiime2
-pkgver=2019.1.0
+pkgver=2020.8.0.dev0
pkgrel=1
pkgdesc="the QIIME 2 framework"
-arch=('any')
+arch=('x86_64')
url="https://qiime2.org"
-license=('BSD 3-Clause License')
-depends=('python' 'python-yaml' 'python-decorator' 'python-tzlocal' 'python-dateutil' 'python-pyparsing' 'python-pyparsing' 'python-pandas' 'python-bibtexparser-git')
+license=('BSD')
+depends=('python' 'python-yaml' 'python-decorator' 'python-tzlocal' 'python-dateutil' 'python-pyparsing' 'python-pyparsing' 'python-pandas' 'python-bibtexparser' 'python-networkx')
makedepends=('python-setuptools')
source=("https://github.com/qiime2/qiime2/archive/${pkgver}.tar.gz")
-sha256sums=('2c8cb4d6ea4a9dbc5876005b75b0d922ed6c861601002d340c2b991af28097b9')
+sha256sums=('76560682412d4da250fd641bc3c5c54e48c9ed2ad2c69bf686c19b3be1b0541a')
build() {
cd "$srcdir/qiime2-$pkgver"
python setup.py build
}
-
package(){
cd "$srcdir/qiime2-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}
# vim:ts=2:sw=2:et: