summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorredponike2025-03-03 16:37:34 +0100
committerredponike2025-03-03 16:37:34 +0100
commitfeb7d7e3b27163268821f71accfa2574c0d21ef9 (patch)
tree3fdc223d8644ad63c38eb2aea3dc1f17838a74cf /PKGBUILD
parent2e572099ff22faedd35608f3548f2c71f3aabdbc (diff)
downloadaur-python-qutip.tar.gz
upgpkg: 5.1.1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 17 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5416865f8414..16152cd8a47b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
-# Maintainer:
+# Maintainer: redponike <proton (dot) me>
# Contributor: Marcell Meszaros < marcell.meszaros AT runbox.eu >
# Contributor: Ray Ganardi <rayganardi [at] gmail [dot] com>
# Contributor: Andres F. Urquijo <alfagalileox@gmail.com>
# Contributor: Sebastian Krämer <basti.kr@gmail.com>
-_distname=qutip
-pkgname="python-${_distname}"
-pkgver=4.7.6
+pkgname="python-qutip"
+_pkgname=${pkgname#python-}
+pkgver=5.1.1
pkgrel=1
pkgdesc="QuTiP is open-source software for simulating the dynamics of open quantum systems"
arch=('x86_64')
@@ -15,16 +15,17 @@ license=('BSD-3-Clause')
depends=(
'gcc-libs'
'glibc'
- 'python'
'python-numpy'
'python-packaging'
- 'python-scipy<1.13'
+ 'python-scipy'
)
makedepends=(
- 'cython0'
+ 'cython'
'gcc-fortran'
'python-setuptools'
'python-wheel'
+ 'python-build'
+ 'python-installer'
)
checkdepends=(
'ipython'
@@ -32,7 +33,7 @@ checkdepends=(
'python-pytest'
)
optdepends=(
- "cython0: Runtime complilation support"
+ "cython: Runtime complilation support"
"ipython: Interactive REPL support"
"psutils: PostScript support"
"python-cvxopt: Convex optimization support"
@@ -42,25 +43,26 @@ optdepends=(
"texlive-bin: Optional, Needed if using LaTeX in figures."
)
source=("https://github.com/qutip/qutip/releases/download/v${pkgver}/qutip-${pkgver}.tar.gz")
-b2sums=('6f511a731d4945b26d9445969bc6c7b20008c5fe1f5d580710318df37626e9a52565220ca170a9c1bb679ff07982b8db26b86a78640746eadb4fe40d33b1c79d')
+b2sums=('032834ebf4cd001aee9aa064ddac4fc5f95899fa497f5e085b1407bebfad24034d68964dcf0df8cca214a9adf715ab771faad6d6f99018f31119ee0792c97684')
_site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
build() {
- cd "$srcdir/$_distname-$pkgver"
- python setup.py build
+ cd $_pkgname-$pkgver
+ python -m build --wheel --no-isolation
}
check() {
- cd "$srcdir/$_distname-$pkgver"
- python setup.py install --root="$PWD/tmp_install" --optimize=1
+ cd "$srcdir/$_pkgname-$pkgver"
+ # pytest -v --pyargs qutip.tests
+ python -m installer --destdir="$PWD/tmp_install" dist/*.whl
cd "$PWD/tmp_install"
PATH="$PWD/usr/bin:$PATH" PYTHONPATH="$PWD$_site_packages:$PYTHONPATH" python -c 'import qutip.testing; qutip.testing.run()'
}
package() {
- cd "$srcdir/$_distname-$pkgver"
- python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 --skip-build
+ cd $_pkgname-$pkgver
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -D -m644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
echo "Removing unneeded tests dir..."