summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGuillaume Horel2021-11-19 09:39:55 -0500
committerGuillaume Horel2021-11-19 09:39:55 -0500
commite031a9bf97cd5fafc5b9493078b69b758b04c9ce (patch)
tree7ab2a92c317de4bfd9ec8a8d96fbb5e049d2eb6e /PKGBUILD
downloadaur-python-ratelimit.tar.gz
initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b69b32f584da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+
+pkgname=python-ratelimit
+_pkgname=ratelimit
+pkgver=2.2.1
+pkgrel=1
+pkgdesc="API rate limit decorator"
+arch=('any')
+url="https://github.com/tomasbasham/ratelimit"
+license=('MIT')
+depends=('python')
+optdepends=()
+makedepends=('python-setuptools')
+source=("https://pypi.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('af8a9b64b821529aca09ebaf6d8d279100d766f19e90b5059ac6a718ca6dee42')
+
+build(){
+ cd "$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package(){
+ cd "$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}
+
+## vim:ts=2:sw=2:et: