summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuiz Amaral2024-09-16 16:46:05 +0200
committerLuiz Amaral2024-09-16 16:46:05 +0200
commit60e443295faeb6f1e0e3d0cc9e4ed47d85035171 (patch)
tree99f49e924fb25f87065d60a743ef1289fef2ea88 /PKGBUILD
downloadaur-python-redfish.tar.gz
Package python-redfish version 3.2.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..322512d15b78
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+pkgname='python-redfish'
+_name=${pkgname#python-}
+
+# Maintainer: Luiz Amaral <email at luiz dot eng dot br>
+pkgver=3.2.5
+pkgrel=1
+pkgdesc='Redfish Python Library'
+arch=('any')
+license=('BSD-3-Clause')
+url='https://pypi.python.org/pypi/redfish'
+
+depends=('python' 'python-requests' 'python-six' 'python-jsonpointer' 'python-requests-toolbelt' 'python-jsonpatch' 'python-jsonpath-rw' 'python-requests-unixsocket')
+provides=('python-redfish')
+makedepends=('python-build' 'python-installer' 'python-wheel')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('cfe778386b5e408075689236cdcb32b191add69a269e6d3cf64e55624b2970d7')
+
+build() {
+ cd $_name-$pkgver
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd $_name-$pkgver
+ install -Dm644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}