summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRichard PALO2020-02-16 13:42:25 +0100
committerRichard PALO2020-02-16 13:42:25 +0100
commit120137031c850943e0966f1d3cd818010ff0b4d9 (patch)
tree324675fdc2b9d09bda69454f168854ef271238e4 /PKGBUILD
parent8a7a45e7ca7454591f3738d9188263241b714ec5 (diff)
downloadaur-120137031c850943e0966f1d3cd818010ff0b4d9.tar.gz
upgrade relatorio to 0.9.1
CHANGES: 0.9.1 - 20200126 * Do not guess type of cell if directive is not alone * Add support for Python 3.8 * Support file-magic as fallback to python-magic
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 4 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bdc7a2d89b02..fcf4a3a652b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,15 @@
# Contributor: Florian Walch <florian.walch@gmx.at>
# Maintainer: Robin Baumgartner <robin@baumgartners.ch>
pkgname=('python-relatorio' 'python2-relatorio')
-pkgver=0.9.0
-pkgrel=2
+pkgver=0.9.1
+pkgrel=1
pkgdesc="A templating library able to output odt and pdf files"
arch=('any')
url="http://relatorio.tryton.org/"
license=('GPL')
makedepends=('python-setuptools' 'python2-setuptools')
-source=("https://pypi.io/packages/source/r/relatorio/relatorio-$pkgver.tar.gz"
- 'ebec469f4baa.diff')
-sha512sums=('d8f5c2a6c6fd207de4f651a8abe8802de0a0a30b35c659136e52868c5721f719e53bc771019a8a4448615432696c149298b2306fcacadcc0737fa6b08a53b345'
- '3c3292bcc9995f1a06c3112eccaa359090baa8182d0ba282a1c2455374144b5e921830788d28161404265637d6450267bee3dcaa906640d8fa06d16c9bc75b9d')
+source=("https://pypi.io/packages/source/r/relatorio/relatorio-$pkgver.tar.gz")
+sha512sums=('1bbbf08f1003f94f18f35c0ed2d3ba9064d336c26997d96231f6523218941d926bc259caa8912f049fc6262649c0a1ebb38c8dbc3740be1d730abe69e5118964')
prepare() {
cp -a relatorio-$pkgver{,-py2}
@@ -20,11 +18,9 @@ prepare() {
build() {
cd "$srcdir/relatorio-$pkgver"
- patch -p1 < ../ebec469f4baa.diff
python setup.py build
cd "$srcdir/relatorio-$pkgver-py2"
- patch -p1 < ../ebec469f4baa.diff
python2 setup.py build
}