summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaxibami2024-09-02 00:49:23 +0900
committerhaxibami2024-09-02 00:49:23 +0900
commit69489ae22ab6458afc5e20dc365ea31edaa0de23 (patch)
tree5a8debdf57c106e206b2796d2641f377896ef24a /PKGBUILD
downloadaur-python-remotezip.tar.gz
0.12.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28a85325b846
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: haxibami <contact at haxibami dot net>
+
+pkgname=python-remotezip
+pkgver=0.12.3
+pkgrel=1
+pkgdesc='Python module to access single members of a zip archive without downloading the full content from a remote web server'
+arch=('any')
+url='https://github.com/gtsystem/python-remotezip'
+license=('MIT')
+depends=('python' 'python-requests')
+makedepends=('python-build' 'python-wheel' 'python-installer' 'python-setuptools')
+checkdepends=('python-requests-mock')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('662bd0859b25d90e41a0698fb694bd90ba5e2b4591e101bbb44984f7943aeb42')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python -m build --wheel --no-isolation
+}
+
+check() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python test_remotezip.py
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}