summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGeorge Rawlinson2021-06-10 23:15:36 +0000
committerGeorge Rawlinson2021-06-10 23:15:36 +0000
commit9cc0826a508f3751bfc37112e5bd3842b200754c (patch)
treed1d3303c205e611cbd6c1826fa263e4a30b98bcc /PKGBUILD
parent9640c09703fd10d3ceee06d532ffe4ff24ec082f (diff)
downloadaur-python-requests-unixsocket.tar.gz
upgpkg: python-requests-unixsocket 0.2.0-2
* Fixed setuptools warnings * Added missing makedepends (python-pbr)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9ea2b6fc0790..8c4d3da783f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,16 +4,24 @@
pkgname=python-requests-unixsocket
_name="${pkgname#python-}"
pkgver=0.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="Use requests to talk HTTP via a UNIX domain socket"
arch=('any')
depends=('python' 'python-requests' 'python-urllib3')
-makedepends=('python-setuptools' 'python-pip')
+makedepends=('python-setuptools' 'python-pip' 'python-pbr')
url="https://github.com/msabramo/requests-unixsocket"
license=('Apache')
options=('!emptydirs')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-b2sums=('cda02b5d963b00fb06cf86819bcbf552ecc21e30064198da338f502f47547a1f93184fd06052047c6cb8a6181f0a2f7b7a7cc53183b18dc22165a41dc14144b5')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz"
+ 'fix_setuptools_warnings.patch')
+b2sums=('cda02b5d963b00fb06cf86819bcbf552ecc21e30064198da338f502f47547a1f93184fd06052047c6cb8a6181f0a2f7b7a7cc53183b18dc22165a41dc14144b5'
+ 'fdb486b0916eb8293b21510aa9dcae9875eb8d6bcb00d1aa3b0278fbe25b12d97df35682199ba468c98ca2ae58b9281a7a44c815600e19e5ff796bbbdd27380a')
+
+prepare() {
+ cd "$_name-$pkgver"
+
+ patch --forward --input="${srcdir}/fix_setuptools_warnings.patch"
+}
build() {
cd "$_name-$pkgver"