summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKartik Mohta2020-05-31 11:22:00 -0700
committerKartik Mohta2020-05-31 11:22:00 -0700
commita3dc83e19d55236ed774f2c1e43fcf054db7583b (patch)
tree7b7ba4f0abcff7430c81af8fc53a541127625e1f /PKGBUILD
parentad7ac99fd3a801ae6f5fad4eef3205da88bebefc (diff)
downloadaur-python-rosinstall.tar.gz
Switch source to github repo
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9cd1502f1278..5091c81a6029 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: Kartik Mohta <kartikmohta@gmail.com>
-pkgbase='python-rosinstall'
pkgname=('python-rosinstall')
-_module='rosinstall'
pkgver='0.7.8'
-pkgrel=4
-pkgdesc="The installer for ROS"
-url="http://wiki.ros.org/rosinstall"
+pkgrel=5
+pkgdesc='Command-line tools for maintaining a workspace of projects from multiple version-control systems, tailored for the ROS community'
+arch=('any')
+url='https://github.com/vcstools/rosinstall'
+license=('BSD')
depends=('python' 'python-catkin_pkg' 'python-rosdistro' 'python-vcstools' 'python-wstool' 'python-yaml')
-conflicts=('python2-rosinstall')
makedepends=('python-setuptools')
-license=('BSD')
-arch=('any')
-source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
-sha256sums=('2ba808bf8bac2cc3f13af9745184b9714c1426e11d09eb96468611b2ad47ed40')
+
+conflicts=('python2-rosinstall')
+source=("https://github.com/vcstools/rosinstall/archive/${pkgver}.tar.gz")
+sha256sums=('ce1266e63aaefccabb4b0aefc56f8cceb45d4e188a4ecad2f623cbb4a5b1843f')
+
+_module='rosinstall'
build() {
cd "${srcdir}/${_module}-${pkgver}"