summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDrRac272023-06-09 09:46:56 +0200
committerDrRac272023-06-09 09:46:56 +0200
commit2fdb50b5c242f163fd86cd20ae08836d8f964d54 (patch)
tree4691c7d7e93f28d98f8888cd6abe2ca4afc860b4 /PKGBUILD
parent547e81ad9152317b49486a2c49a0f8e86f95dadb (diff)
downloadaur-python-rply.tar.gz
fix build by moving from py.test to pytest
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 16 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 555704dd5f02..44e0b48a47a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Maintainer: DrRac27 <drrac27 at riseup dot net>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
pkgname=python-rply
pkgver=0.7.8
@@ -9,8 +10,19 @@ license=('BSD')
url="https://rply.readthedocs.org"
makedepends=('python-setuptools' 'python-appdirs')
checkdepends=('python-pytest')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/alex/rply/archive/v$pkgver.tar.gz")
-sha512sums=('b43e6425f046561cfca616801d37d7151f015aeb2ea2365abc00f97fd6b41f1a01a17e330aed5a81537065e4b29d49cd0824b5a5cb8b2d11da2ff1f8de952fce')
+source=(
+ "$pkgname-$pkgver.tar.gz::https://github.com/alex/rply/archive/v$pkgver.tar.gz"
+ '0001-replace-py-with-pytest.patch'
+)
+sha512sums=(
+ 'b43e6425f046561cfca616801d37d7151f015aeb2ea2365abc00f97fd6b41f1a01a17e330aed5a81537065e4b29d49cd0824b5a5cb8b2d11da2ff1f8de952fce'
+ 'f22b2e300a43f44755668a3984525639968347f3bcb0c220829590af4da7eca4877230ec27b844dab6da27655ab75fe867ce04a8b67822d5a9b3a4c3cafcd537'
+)
+
+prepare() {
+ cd "$srcdir"
+ patch -p1 -d rply-$pkgver < '0001-replace-py-with-pytest.patch'
+}
build() {
cd "$srcdir"/rply-$pkgver
@@ -19,7 +31,7 @@ build() {
check() {
cd "$srcdir"/rply-$pkgver
- py.test
+ pytest
}
package() {